Jump to content


glibc problem 2.36 / open source?


  • Please log in to reply
1 reply to this topic

#1 Guest_titi_*

Guest_titi_*
  • Guests

Posted 27 August 2007 - 08:49 PM

Hi, We( my friends my kids and I) have problems running IO due to libc-version problems.
We are all using Ubuntu-6.06-Dapper-LTS( LTS=LongTermSupport ) with glibc Version 2.36......

Is there any possibility to get a working Version for glibc 2.36???


What about the sourcecode? Is IO open source?
Where can I download the sourcecode?
If it's open source, I can probably build a glibc2.36-version ...

#2 cfraz89

cfraz89

    Vigilante

  • Member
  • PipPipPip
  • 339 posts
  • Gender:Male
  • Location:Australia

Posted 28 August 2007 - 12:48 PM

Hi titi.
I was hoping that the standard build would work with glibc > 2.2, since I used a special build process that was meant to build against 2.2, and glibc is supposed to be backward compatible. But it seems like that didn't work, since theres many people like you with glibc problems. I actually built the game on a feisty system.

The game is indeed open source, since its written in python the source is executed directly by the interpreter. So what you downloaded actually is the game's source. Have a look inside the game's folders, its choc full of code. The build that we're referring to is the celstart (crystal space and cel) framework on which the game was built.

If you feel adventorous / desperate and want to compile celstart yourself:
this thread has the goods




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users